威廉希尔中文网站

?
400-818-6868

安全研究

威胁通告
Linux邮件传输代理Exim缓冲区溢出漏洞 (CVE-2018-6789)
综述
Linux的邮件传输代理Exim被曝出存在一个漏洞(CVE-2018-6789)。该漏洞源于base64解码函数中的一个缓冲区溢出问题。常规下base64编码后的字符串的长度为4的倍数,但是有可能在传输或者恶意构造的情况下导致长度不为4的倍数,致使长度计算错误。通过该漏洞,攻击者可以绕过防护机制在受影响的应用程序上下文中执行任意代码。若攻击尝试失败仍可导致拒绝服务条件。
威廉希尔中文网站威胁情报中心(NTI)显示全球Exim用量超过百万级,该漏洞影响Exim发行以来所有版本,建议受影响的用户立即升级进行防护。

 



相关链接:
http://www.openwall.com/lists/oss-security/2018/02/07/2
https://www.exim.org/static/doc/security/CVE-2018-6789.txt
https://devco.re/blog/2018/03/06/exim-off-by-one-RCE-exploiting-CVE-2018-6789-en/


受影响的版本

 Exim versions < 4.90.1


不受影响的版本

 Exim version 4.90.1


解决方案
Exim已经发布了新版本4.90.1修复了上述漏洞,威廉希尔中文网站建议受影响的用户立即升级至最新版本进行防护。

官方修复代码如下,用户也可以自行修改代码重新编译来修复该漏洞。


 


 
参考链接:
https://github.com/Exim/exim/commit/cf3cd306062a08969c41a1cdd32c6855f1abecf1

声 明
本安全公告仅用来描述可能存在的安全问题,威廉希尔中文网站不为此安全公告提供任何保证或承诺。由于传播、利用此安全公告所提供的信息而造成的任何直接或者间接的后果及损失,均由使用者本人负责,威廉希尔中文网站以及安全公告作者不为此承担任何责任。威廉希尔中文网站拥有对此安全公告的修改和解释权。如欲转载或传播此安全公告,必须保证此安全公告的完整性,包括版权声明等全部内容。未经威廉希尔中文网站允许,不得任意修改或者增减此安全公告内容,不得以任何方式将其用于商业目的。


浏览次数:

关 闭
XML 地图 | Sitemap 地图